EasyEngine v3.5.5 for WordPress 4.5 and Let’s Encrypt Auto-Renewal Fix

Today, WordPress 4.5 “Coleman” was released.  This WordPress release requires WP-CLI version 0.23, as older WP-CLI versions are not compatible with WordPress 4.5. For more details check WP-CLI blog post.

We have updated WP-CLI version inside EasyEngine core and released a minor update as EasyEngine version 3.5.5.

Updating EasyEngine

Current EasyEngine users can update EasyEngine using following command.

ee update

This will trigger a check for WP-CLI version running on your server and update WP-CLI to the latest release.

If you are installing EasyEngine on a new server, then by default the latest version of WP-CLI and WordPress will be installed. You need not take any other action.

If for some reason you cannot update EasyEngine or running very old version of EasyEngine, please update WP-CLI version manually.

Let’s Encrypt Auto-renewal fix

A small change in Let’s Encrypt API broke auto-renewal of SSL certificates created by EasyEngine. Yep, EasyEngine already supports Let’s Encrypt based SSL certificates.

This EasyEngine version has necessary to fix to offset Let’s Encrypt API change. The concern issue is on Github at https://github.com/EasyEngine/easyengine/issues/702.

If you have faced any issue around Let’s Encrypt certificate auto-renewals, you likely benefit from this minor fix.

Links: EasyEngine Release Notes | WP-CLI Blog Post

Leave a Reply