Solution for Cannot create/start proxy container

This article is written for people who are getting “Cannot create/start proxy container” error message and who had installed EasyEngine between 31st October 2018 to 29th November 2018.

Before following the rest of the article, first check your docker-compose version with

docker-compose -v

If it is v1.23.0 or v1.23.1, this article will be relavant to you. If the version differs, do not follow the article.

ADVERTISEMENT

The reason you are getting this error message is because of one particular change that was introduced in docker-compose v1.23.0. That change was again reverted back in v1.23.2. So if you happen to have installed EasyEngine during this time, you might be getting this error. You can read our github issue to know about the issue in detail.

This error needs to be fixed manually and you have to follow below steps to fix it:

1. Update docker-compose to latest version.

sudo curl -L https://github.com/docker/compose/releases/download/1.23.2/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose
sudo chmod +x /usr/local/bin/docker-compose

2. Restart global-services:

cd /opt/easyengine/services && \
docker-compose down && \
docker-compose up -d 

3. Restart sites:

for site in $(ee site list --format=text); do ee site disable $site && ee site enable $site; done